WDCP面板基于PHP5.5.38安装swoole扩展支持

文章目录

  • 第一、下载和解压Swoole
  • 第二、安装Swoole
  • 第三、重启生效Swoole

Swoole,是一种PHP高级Web开发框架,可以提升网站的开发效率,最少的性能损耗,换取最大的开发效率。我们可以利用Swoole框架,开发一些复杂的Web功能,可以在比较短时间内完成。Swoole可以广泛应用于互联网、移动通信、企业软件、网络游戏、物联网、车联网、智能家庭等领域。Swoole从2.0版本开始支持了内置协程,可以使用完全同步的代码实现异步程序。PHP代码无需额外增加任何关键词,底层自动进行协程调度,实现异步。

在一般的应用中,蜗牛也没有接触到要使用Swoole,这不早上有一个朋友需要在WDCP面板环境中安装支持Swoole,所以我就在上面一段搜索了关于Swoole的介绍,其实我也没明白具体干嘛用的,既然他要安装,那就参考下文档在当前WDCP面板WEB环境中给他安装Swoole扩展。

根据以往的WDCP扩展的安装,是需要针对不同的PHP版本的,这里当前默认的WDCP PHP是5.5.38,这里就在这个版本下安装Swoole,其他如果有不同版本PHP也是有类似的参考。

WDCP相关其他扩展安装支持可以参考这几篇文章:

1、记录一次WDCP面板基于PHP5.3/5.4/5.5安装soap扩展步骤

2、WDCP V3版本修改8080端口和常用安全设置及安装ionCube Loader

3、WDCP面板Web环境安装redis与phpredis扩展应用方法

文章目录
隐藏

第一、下载和解压Swoole

第二、安装Swoole

第三、重启生效Swoole

第一、下载和解压Swoole

yum install unzip zip -y
wget https://soft.itbulu.com/wdcp/swoole-src-swoole-1.7.21-stable.zip
unzip swoole-src-swoole-1.7.21-stable.zip
cd swoole-src-swoole-1.7.21-stable

第二、安装Swoole

1、执行

/www/wdlinux/apache_php-5.5.38/bin/phpize

这里我们需要在当前PHP5.5.38中安装,如果有多个PHP同存,我们需要看清楚哪个要安装就在哪里执行。

2、编译

./configure –with-php-config=/www/wdlinux/apache_php-5.5.38/bin/php-config

编译设置,然后安装。

make
make install

这里要注意最后extensions一行路径等会需要用的。

3、修改扩展文件

extension=/www/wdlinux/apache_php-5.5.38/lib/php/extensions/no-debug-non-zts-20121212/swoole.so

因为当前这个朋友是用的PHP5.5.38,所以在其php.ini文件中添加扩展路径,保存替换。

第三、重启生效Swoole

1、执行重启

service httpd restart

重启WEB之后应该是生效了,我们检查一下。

2、检查是否生效

可以看到,当前Swoole扩展已经安装生效,具体如何使用我就不研究了,因为我还用不到。

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

【声明】:本评测不参与任何交易,也非中介,仅记录个人感兴趣的主机测评结果和优惠活动,内容均不作直接、间接、法定、约定的保证。访问本博客请务必遵守有关互联网的相关法律、规定与规则。一旦您访问本博客,即表示您已经知晓并接受了此声明通告

木沐主机评测 国外服务器主机评测 WDCP面板基于PHP5.5.38安装swoole扩展支持 https://www.mumupc.com/archives/11296.html

常见问题

相关文章

发表评论
暂无评论
官方客服团队

为您解决烦忧 - 24小时在线 专业服务

  • 0 +

    访问总数

  • 0 +

    会员总数

  • 0 +

    文章总数

  • 0 +

    今日发布

  • 0 +

    本周发布

  • 0 +

    运行天数

你的前景,远超我们想象